package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w_]+).*?([\w_]+)\(\+\)`)
var str = `a.deptno = b.dept_no(+)
c.deptno(+)=b.dept_no
a.deptno(+)= 900
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}