import Foundation
let pattern = #"(?=query|mutation).+?(?=query|mutation|\Z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
query get_telemetry (name: String, start_time: String, end_time: String) {
parameters:satelliteOperatorInteractionParameters(name: $name) {
edges {
node {
name
path
states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {
edges {
node {
timestamp
calibrated_value:calibratedValue
}
}
}
}
}
}
}
mutation get_all_possible_parameters {
parameters:satelliteOperatorInteractionParameters {
edges {
node {
path
}
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)