const regex = new RegExp('\\w+ \\w+ \\(OBJECT\\) \\@[a-z0-9]+', 'gm')
const str = `SCALAR_NaN ceil (SCALAR_NaN) @7ff710295590
SCALAR waypointVisible (ARRAY) @7ff70f56e030
NOTHING enableSatNormalOnDetail (BOOL) @7ff70f1a0d90
ARRAY getPosATL (OBJECT) @7ff70f1e9df0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}