using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Sys.Process\(\""axium\""\)(\.Window\((\""{0,1}(\&*\#*\d*\w*\:*\s*\.*\w*){1,10}\""{0,1}\,{0,1}\s{0,2}){1,3}\)){1,10}\.\w*\(*(\""*\^*\[*\]*\w*\d*\x81*\d*\""*\,*\s*){1,10}\)*";
string input = @"Sys.Process(""axium"").Window(""DX::MainFrame"", ""axiUm*"").Window(""MDIClient"").Window(""OWL_Window"", ""Inventory"").Window(""#32770"", ""Inventory"").Window(""Button"", ""&Transfer..."").ClickButton();";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}