const regex = /Sys.Process\(\"axium\"\)(\.Window\((\"{0,1}(\&*\#*\d*\w*\:*\s*\.*\w*){1,10}\"{0,1}\,{0,1}\s{0,2}){1,3}\)){1,10}\.\w*\(*(\"*\^*\[*\]*\w*\d*\x81*\d*\"*\,*\s*){1,10}\)*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Sys.Process\\(\\"axium\\"\\)(\\.Window\\((\\"{0,1}(\\&*\\#*\\d*\\w*\\:*\\s*\\.*\\w*){1,10}\\"{0,1}\\,{0,1}\\s{0,2}){1,3}\\)){1,10}\\.\\w*\\(*(\\"*\\^*\\[*\\]*\\w*\\d*\\x81*\\d*\\"*\\,*\\s*){1,10}\\)*', 'gmi')
const str = `Sys.Process("axium").Window("DX::MainFrame", "axiUm*").Window("MDIClient").Window("OWL_Window", "Inventory").Window("#32770", "Inventory").Window("Button", "&Transfer...").ClickButton();`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}