re = /Sys.Process\(\"axium\"\)(\.Window\((\"{0,1}(\&*\#*\d*\w*\:*\s*\.*\w*){1,10}\"{0,1}\,{0,1}\s{0,2}){1,3}\)){1,10}\.\w*\(*(\"*\^*\[*\]*\w*\d*\x81*\d*\"*\,*\s*){1,10}\)*/mi
str = 'Sys.Process("axium").Window("DX::MainFrame", "axiUm*").Window("MDIClient").Window("OWL_Window", "Inventory").Window("#32770", "Inventory").Window("Button", "&Transfer...").ClickButton();'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end