$re = '/\b(?![01]\b)\d{1,4}\b/';
$str = '0
1
2
3
4
5
6
10
99
101
999
9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);