# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*SYSLOG_ROW\]\s*(.*,\s*)?"
test_str = ("2019-06-28 15:02:09:933 - info: [bUSLog] [bUS_SYSLOG_ROW] Jun 28 11:02:09 device—Target ABC-DEF[365] Notice: -[sendAllDataToServerWithDebug:] [Line 255] Event uploaded, ABCAccount : {\n"
"2019-06-28 15:02:09:933 - info: [bUSLog] [bUS_SYSLOG_ROW] dcis = 0;\n"
"2019-06-28 15:02:09:933 - info: [bUSLog] [bUS_SYSLOG_ROW] ttl = 0;\n"
"2019-06-28 15:02:09:933 - info: [bUSLog] [bUS_SYSLOG_ROW] bb = 0;\n"
"2019-06-28 15:02:09:933 - info: [bUSLog] [bUS_SYSLOG_ROW] r1 = 1234567890;\n"
"2019-06-28 15:02:09:934 - info: [bUSLog] [bUS_SYSLOG_ROW] pop = abc;\n"
"2019-06-28 15:02:09:934 - info: [bUSLog] [bUS_SYSLOG_ROW] origin = target;\n"
"2019-06-28 15:02:09:934 - info: [bUSLog] [bUS_SYSLOG_ROW] \"tsn\" = “l323f123f”;\n"
"2019-06-28 15:02:09:934 - info: [bUSLog] [bUS_SYSLOG_ROW] }\n"
"2019-06-28 15:02:09:934 - info: [bUSLog] [bUS_SYSLOG_ROW] Jun 28 11:02:09 device—Target ABC-DEF[365] Notice: -[sendAllDataToServerWithDebug:] [Line 255] Event uploaded, ABCAccount : {\n"
"2019-06-28 15:02:09:935 - info: [bUSLog] [bUS_SYSLOG_ROW] dcis = 0;\n"
"2019-06-28 15:02:09:935 - info: [bUSLog] [bUS_SYSLOG_ROW] ttl = 0;\n"
"2019-06-28 15:02:09:935 - info: [bUSLog] [bUS_SYSLOG_ROW] bb = 0;\n"
"2019-06-28 15:02:09:935 - info: [bUSLog] [bUS_SYSLOG_ROW] r1 = NA;\n"
"2019-06-28 15:02:09:935 - info: [bUSLog] [bUS_SYSLOG_ROW] pop = abc;\n"
"2019-06-28 15:02:09:936 - info: [bUSLog] [bUS_SYSLOG_ROW] origin = source;\n"
"2019-06-28 15:02:09:936 - info: [bUSLog] [bUS_SYSLOG_ROW] \"tsn\" = “lasdf23f23”;\n"
"2019-06-28 15:02:09:936 - info: [bUSLog] [bUS_SYSLOG_ROW] }\n"
"2019-06-28 15:02:09:936 - info: [bUSLog] [IOS_SYSLOG_ROW] Jun 28 11:02:09 device—Target ABC-DEF[365] Notice: -[sendAllDataToServerWithDebug:] [Line 255] Event uploaded, ABCAdditional : {\n"
"2019-06-28 15:02:09:937 - info: [bUSLog] [IOS_SYSLOG_ROW] add1 = value;\n"
"2019-06-28 15:02:09:937 - info: [bUSLog] [IOS_SYSLOG_ROW] add2 = false;\n"
"2019-06-28 15:02:09:937 - info: [bUSLog] [IOS_SYSLOG_ROW] pop = abc;\n"
"2019-06-28 15:02:09:937 - info: [bUSLog] [IOS_SYSLOG_ROW] origin = target;\n"
"2019-06-28 15:02:09:937 - info: [bUSLog] [IOS_SYSLOG_ROW] “tsn” = “g254g34gg4g”;\n"
"2019-06-28 15:02:09:937 - info: [bUSLog] [IOS_SYSLOG_ROW] \"time_zone\" = EDT;\n"
"2019-06-28 15:02:09:938 - info: [bUSLog] [IOS_SYSLOG_ROW] }")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.