$re = '/&|\||#/m';
$str = 'Teste1 & Teste2 # Teste3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);