package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<symbol>[$¥£€₹])(?P<amount>\d{1,10}(?:[.,]\d{1,10})?)(?:\h+(?P<currency>AUD|USD|GBP|EURO?S?)\b)?\b|(?P<amount>\d{1,10}(?:[.,]\d{1,10})?)\h+(?P<currency>AUD|USD|GBP|EURO?S?)\b`)
var str = `$20,000 AUD
$20,000
20,000 AUD
$
20,000
AUD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}