import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<symbol>[$¥£€₹])(?P<amount>\\d{1,10}(?:[.,]\\d{1,10})?)(?:\\h+(?P<currency>AUD|USD|GBP|EURO?S?)\\b)?\\b|(?P<amount>\\d{1,10}(?:[.,]\\d{1,10})?)\\h+(?P<currency>AUD|USD|GBP|EURO?S?)\\b";
final String string = "$20,000 AUD\n"
+ "$20,000\n"
+ "20,000 AUD\n\n"
+ "$\n"
+ "20,000\n"
+ "AUD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}