const regex = /(?P<symbol>[$¥£€₹])(?P<amount>\d{1,10}(?:[.,]\d{1,10})?)(?:\h+(?P<currency>AUD|USD|GBP|EURO?S?)\b)?\b|(?P<amount>\d{1,10}(?:[.,]\d{1,10})?)\h+(?P<currency>AUD|USD|GBP|EURO?S?)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<symbol>[$¥£€₹])(?P<amount>\\d{1,10}(?:[.,]\\d{1,10})?)(?:\\h+(?P<currency>AUD|USD|GBP|EURO?S?)\\b)?\\b|(?P<amount>\\d{1,10}(?:[.,]\\d{1,10})?)\\h+(?P<currency>AUD|USD|GBP|EURO?S?)\\b', 'gm')
const str = `\$20,000 AUD
\$20,000
20,000 AUD
\$
20,000
AUD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}