$re = '/^this is a ("|)([^"\s]+)(\1)\s*$/s';
$str = 'this is a "xyz"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);