$re = '/^(?=.*[1-9])(?!0\d)(\d{0,3}(?:\.\d{1,2})?)$/m';
$str = 'Should match: (if decimal exists, max 3 numbers before and 2 after.)
.01
.1
0.01
0.1
1
10
10.1
10.11
105.1
999.99
88.00
Should fail:
12345678.54
00564.5412
00.451
1.
,25
..25
0025
01
00,25
0
.0
0.001
999.001
e123.12
1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);