// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"20241118").unwrap();
let string = "s3://snowflake-iagedh-dev/cxone/telemetry/20241118112007_changed_data_activity_fact_view_v001.csv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}