$re = '/(\bgout)(s\b|\b)/mi';
$str = 'technicien de maintenance H/F
technicien de maintenance H/F.
technicien de maintenance en chimie H/F.
technicien de maintenance
technicien de maintenance.
Technicien de maintenance industrielle.
Il faut vérifier les cout et les couts ici.
Remplacemenent de mots spécifiques tels cout, gout, maitrise et tache mais pas ragout ni ecoute,ni coût.
';
$subst = "goût$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;