$re = '/<a href=".*?"/m';
$str = '<td>
[<a href="/abc123/handouts/files/directory1/somename.pdf" target="_blank">Slides</a> ] [ [<a href="/abc123/handouts/files/directory2/somename2.pdf" target="_blank">Handout</a> ]</td>
<td>
[<a href="/abc123/handouts/files/directory3/somename343.pdf" target="_blank">Slides</a> ] [ <a href="/abc123/handouts/files/directory5/somename2324.pdf" target="_blank">Handout</a> ]
</td>';
$subst = "<a href=\"#\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;