import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\(\\w)*\\\\";
final String string = "D:\\pcap\\WebMail\n"
+ "D:\\pcap1\\WebMail\\1\\1\n"
+ "C:\\pcap\\WebMail\\sd\\\n"
+ "D:\\pcapFixed\\WebMail\\AOL\\AOL_Accessible\\20121107\\AOL_lite_ACCESSIBLE_001_Login.xml";
final String subst = "\\\\replacedFolder\\\\";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}