using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*[^""]+((?<=[.?!]\s).*lockbox.*(?<=[.?!]))[^""].*)";
string input = @"""krombacher alkoholfrei mw. 24 x 0,33 l bier krombacher alkoholfrei alkohol ist entbehrlich, geschmack nicht das krombacher pilsener alkoholfrei ist eine vollmundige erfrischung. bierkenner werden von dem erfrischend isotonischen durstlöscher überzeugt sein, denn es ist das beliebteste alkoholfreie pils in deutschland. abgefüllt wird es in der 0,33 l mehrwegflasche mit 24 flaschen pro kiste. bestell noch heute bis 23.30 uhr und wir liefern schon morgen mit dem einzigartigen lockboxsystem. Und so weiter."";
""krombacher alkoholfrei mw. 24 x 0,33 l bier krombacher alkoholfrei alkohol ist entbehrlich, geschmack nicht das krombacher pilsener alkoholfrei ist eine vollmundige erfrischung. bierkenner werden von dem erfrischend isotonischen durstlöscher überzeugt sein, denn es ist das beliebteste alkoholfreie pils in deutschland. abgefüllt wird es in der 0,33 l mehrwegflasche mit 24 flaschen pro kiste. bestell noch heute bis 23.30 uhr und wir liefern schon morgen mit dem einzigartigen lockboxsystem. Und so weiter."";";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}