# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s+(?:[13]0|22)"
test_str = ("\"ABC\"\n"
"\"ABC 10\"\n"
"\"ABC 22\"\n"
"\"ABC 30\"\n"
"\"ABC L1\"\n"
"\"ABC L2\"\n"
"\"ABC 10 L1\"\n"
"\"ABC 10 L2\"\n"
"\"ABC 22 L1\"\n"
"\"ABC 22 L2\"\n"
"\"ABC 30 L1\"\n"
"\"ABC 30 L2\"\n"
"\"PQR\"\n"
"\"PQR 10\"\n"
"\"PQR 22\"\n"
"\"PQR 30\"\n"
"\"PQR X3\"\n"
"\"PQR X4\"\n"
"\"PQR 10 X3\"\n"
"\"PQR 10 X4\"\n"
"\"PQR 22 X3\"\n"
"\"PQR 22 X4\"\n"
"\"PQR 30 X3\"\n"
"\"PQR 30 X4\"")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.