re = /^(?:.*?)(?=Hello|:)|^(?!.*(Hello|:)).*$/m
str = 'Let\'s go see Hello Dolly: A Classic Movie
Let\'s go see: A Classic Movie, Hello Dolly
Howdy
Well Hi, Hello My Friend
My Favorite Pizza Place: NYC
Hello
: a movie'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end