import Foundation
let pattern = #"^(?:.*?)(?=Hello|:)|^(?!.*(Hello|:)).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Let's go see Hello Dolly: A Classic Movie
Let's go see: A Classic Movie, Hello Dolly
Howdy
Well Hi, Hello My Friend
My Favorite Pizza Place: NYC
Hello
: a movie
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)