re = /^(.*\.\d{1,})$/m
str = 'name.
File Name.
name.abc
name.1
name.123
name.123.abc
File name.aaa.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end