import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\$|сум)(\\040)?(\\d{1,8})|(\\d{1,8})(\\040)?(?:\\$|сум))$";
final String string = "$23\n"
+ "23$\n"
+ "1000сум\n"
+ "сум1000\n"
+ "сум 1000\n"
+ "1000 сум\n"
+ "1000000000 сум";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}