const regex = /(?=\d{10})\d{5}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\d{10})\\d{5}', '')
const str = `0123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}