$re = '/(?=\d{10})\d{5}/';
$str = '0123456789';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);