package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_(\S+)\.yml$`)
var str = `abcd_1.263.0.15-8zz00df.yml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}