package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<base[ ]*?href=".+"`)
var str = `<html><head><base href="/" /></head><body></body></html>
<html>
<head>
<base href="/"/>
</head>
<body>
</body>
</html>
<html>
<head>
<base href="/">
</head>
<body>
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}