import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<base[ ]*?href=\".+\"";
final String string = "<html><head><base href=\"/\" /></head><body></body></html>\n\n"
+ "<html>\n"
+ " <head>\n"
+ " <base href=\"/\"/>\n"
+ " </head>\n"
+ " <body>\n"
+ " </body>\n"
+ "</html>\n\n"
+ "<html>\n"
+ " <head>\n"
+ " <base href=\"/\">\n"
+ " </head>\n"
+ " <body>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}