# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^)(?=(?:\d{3})+$)/,/gm;t' <<< "12345678
123
1
1234
123456
778123232232"