re = /(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)|(\w)|(<\/\w+)*(\s*>)/
str = '<td class="sky" data-toggle="up" id="heaven" >dddd</a>
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<a href="#" data-toggle="modal" data-target="xxxx"></a>
<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>
<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>
<a id="2" css="sanitizer" href="#modal-collection" data-toggle="modal" data-target="#available-assistance" data-toggle="modal" data-attr-custom="test">collect information</a>
'
subst = '$1$5$7$8'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result