const regex = /(?=(([^"]*"){2})*[^"]*$)(?=(([^']*'){2})*[^']*$)\s*,\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(([^"]*"){2})*[^"]*$)(?=(([^\']*\'){2})*[^\']*$)\\s*,\\s*', 'g')
const str = `abcd, efgh, ij"k,l", mnop, 'q,rs't`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);