# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b/X'\4\3\2\1\6\5\8\7\9\10\11'/gm;t' <<< "f46279ee-aa28-497c-982c-403ac0ea84a6"