package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b`)
var str = `f46279ee-aa28-497c-982c-403ac0ea84a6`
var substitution = "X'\4\3\2\1\6\5\8\7\9\10\11'"
fmt.Println(re.ReplaceAllString(str, substitution))
}