import Foundation
let pattern = #"\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"f46279ee-aa28-497c-982c-403ac0ea84a6"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X'\4\3\2\1\6\5\8\7\9\10\11'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)