package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s,.'-]{2,}|[\s.]`)
var str = `She said - 'That'll be all, Two-Fry.'руский and ไทอ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}