# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#{+[^#{]+}+/\1/i;t' <<< "첫번째#{가나다라마바사}1234567
"