using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#{+[^#{]+}+";
string substitution = @"\1";
string input = @"첫번째#{가나다라마바사}1234567
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}