use strict;
my $str = '첫번째#{가나다라마바사}1234567
';
my $regex = qr/#{+[^#{]+}+/ip;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";