import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)\\b\\d{9}[a-z]?[^\\W_]?\\d{0,3}\\b$";
final String string = "123456789A1\n"
+ "123456789AA\n"
+ "123456789AA123\n"
+ "123456789A1123\n\n"
+ "12345678911234\n"
+ "123456789AA12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}