using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-\s?\([^)]+\).+?\w+:\w+";
string input = @"- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:(NSString *)deltaValueString {
- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {
- (void)transitionToValue:valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {
[self test:asd]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}