re = /\w+=\S*def\S*/
str = 'var s1 = \'label1="abc" label2=\\\'def\\\' \';
var s2 = \'label1="abc" label2=\\\'def\\\' label3="ghi"\';
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end