// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+=\S*def\S*").unwrap();
let string = "var s1 = 'label1=\"abc\" label2=\\'def\\' ';
var s2 = 'label1=\"abc\" label2=\\'def\\' label3=\"ghi\"';
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}