using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s.*href=['""]([^'""]+)['""].*>.*</a>";
string input = @"<a href=""http://stepic.org/"">Sample</a>
<a target=""blank_"" href=""https://stepic.org"">Sample</a>
<a href='http://stepic.org'>Sample</a>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}