import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "foo: [A-Z](?=(?:(?!foo)[^2])*2)";
final String string = "foo: A\n"
+ " 1\n"
+ " 2\n"
+ "foo: B\n"
+ " 1\n"
+ "foo: C\n"
+ " 2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}