const regex = /foo: [A-Z](?=(?:(?!foo)[^2])*2)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('foo: [A-Z](?=(?:(?!foo)[^2])*2)', 'g')
const str = `foo: A
1
2
foo: B
1
foo: C
2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}