# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a\s*(?:href=[\'\"]([^\'\"]+)[\'\"])?\s*(?:title=[\'\"]([^\'\"]+)[\'\"])?.*?>((?:(?!<\/a>).)*)<\/a>"
test_str = ("<a href=\"/test1\" title=\"da\">test</a> \n"
"<a href=\"//stackoverflow.com\">current community</a>\n"
"dwadwad<a href=\"/test2\" title=\"adwa\">test2</a>213213\n"
"<a href=\"/test2\" title=\"adwa\">test2</a>ed<a href=\"/test3\">test2</a>\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.