const regex = new RegExp('\\s*\\([^()]*\\)$', 'g')
const str = `*AWL* (GREATER) MINDS LIMITED (CLOSED)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);