#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\.)\b0(?:\.0+)?(?!\.)\b"
Local $sString = "0" & @CRLF & _
"0.0" & @CRLF & _
"0.0000" & @CRLF & _
"10" & @CRLF & _
"10.0000" & @CRLF & _
"0.122" & @CRLF & _
"25.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")