const regex = /^\/westwing\/(.*)\//m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/westwing\\\/(.*)\\\/', 'm')
const str = `/westwing/
/westwing/something/
/westwing/something/else/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}